Fw: [Samba] printer admin option replacement on stand alone (not domain) print server running version 3.0.25

Vickie L. Kidder Vickie.Kidder at TABASCO.com
Thu Dec 27 22:22:21 GMT 2007

Thanks to those who responded to my original question.

I ran this command and it accepted it after I provided the root password.
# net rpc rights grant 'vlkidder' SePrintOperatorPrivilege

Checked to see if 'vlkidder' had printer admin privilege and it seems ok.
# net rpc rights list accounts
BUILTIN\Print Operators
No privileges assigned


BUILTIN\Account Operators
No privileges assigned

BUILTIN\Backup Operators
No privileges assigned

BUILTIN\Server Operators
No privileges assigned


No privileges assigned

After using the Printer Wizard from Windows to upload the driver, it goes 
through the process of copying the driver files to the [print$] directory, 
but there is still an error in my log file.

  _spoolss_addprinterdriver: Failed to send message about upgrading driver 
[2007/12/27 15:59:26, 1] smbd/service.c:close_cnum(1230)
  vlkidder-06212 ( closed connection to service print$

> I'm trying to upload print drivers to a stand-alone samba server running 

> version 3.0.25.
> The server is part of a workgroup (not domain).
> My log files show messages that it cannot update the driver.
> Before I had the printer admin option set in my smb.conf file to allow a 

> non-root user to do the printer admin and everything worked fine.
> I have read the Samba How To Notes section on important changes since 
> it says the following.
> "Group mappings are essential only if the Samba server is running as a 
> PDC/BDC.  Stand-alone servers do not require these group mappings.".
> Can anyone help me to understand what I need to do to allow a non-root 
> user to perform printer admin functions on a stand-alone server?
> -- 
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list