[Samba] Problems adding a NTSp6a machine to a SAMBA PDC Domain + LDAP: sambaPrimaryGroupSID

Carlos Terrón terron at arrakis.es
Wed Dec 19 14:23:39 GMT 2007

Hello everybody

I have configure a Samba PDC machine, using LDAP as password backend.  
The scripts smbldap-tools are used to create the accounts in the  
LDAP. I can add Windows XP machines to the domain without problems.  
But today, I tried to add a Windows NT Server SP6a machine to the  
domain, and there is the next error:

   smbldap_get_single_attribute: [sambaLogonHours] = [<does not exist>]
[2007/12/19 14:38:03, 10] lib/smbldap.c:smbldap_make_mod(528)
   smbldap_make_mod: adding attribute |sambaLogonHours| value | 
[2007/12/19 14:38:03, 10] lib/smbldap.c:smbldap_make_mod(519)
   smbldap_make_mod: deleting attribute |sambaAcctFlags| values | 
[DW         ]|
[2007/12/19 14:38:03, 10] lib/smbldap.c:smbldap_make_mod(528)
   smbldap_make_mod: adding attribute |sambaAcctFlags| value | 
[W          ]|
[2007/12/19 14:38:03, 5] lib/smbldap.c:smbldap_modify(1377)
   smbldap_modify: dn => [uid=windowsntldap 
[2007/12/19 14:38:03, 10] lib/smbldap.c:smbldap_modify(1397)
   Failed to modify dn: uid=windowsntldap 
$,ou=machines,ou=samba,dc=xxxxx,dc=local, error: 20 (Type or value  
exists) (modify/add: sambaPrimaryGroupSID: value #0 already exists)
[2007/12/19 14:38:03, 5] rpc_parse/parse_prs.c:prs_debug(84)
   000000 samr_io_r_set_userinfo

The smbd proccess have a problem trying to modify the LDAP entry that  
have been created

I have been using the Samba version that came with CentOS 5.1  
(samba-3.0.25b) I also have a tcpdump file from the Samba <-> LDAP  
comunication and I can see the same error:
attributeOrValueExists (modify/add: sambaPrimaryGroupSID: value #0  
already exists)

I don't know what is the problem. Can someone help me?. Thank you  
very much


More information about the samba mailing list