[Samba] Cannot join domain with error: ads_connect: No logon servers

Carlos Ramos nibau.ramos at gmail.com
Tue Dec 18 16:13:26 GMT 2007

there is a switch to specify the server name. I was having a similar
problem that was solved specifying it's name.

net -d ads join -s your_server_dns

don't forget to add your_server_dns to /etc/hosts

On Dec 18, 2007 3:20 AM, Jean-Pierre Gillione <jpg1792 at gmail.com> wrote:
> Hello All,
> I am trying to get a Gentoo Linux system to join a domain run by a Mac
> OS X Server.  I have set up kerberos and ldap as per the instructions
> in the Samba documentation and I am able to log in to the system using
> the info (getent finds the users, and kinit successfully connects),
> but I can't get Samba to join the domain and authenticate the users.
> When I run "net ads join" I get:
> [2007/12/17 19:16:07, 0] utils/net_ads.c:ads_startup_int(286)
>   ads_connect: No logon servers
> Failed to join domain: No logon servers
> I have tried searching google for this, but have found no response.
> Does anybody know what the problem is?
> Thanks for any help.
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list