[Samba] errors when copying large directories to/from samba/windows

Andreas Baitis abaitis at gmail.com
Sat Dec 15 08:03:25 GMT 2007

Jeremy Allison wrote:
> On Sat, Dec 15, 2007 at 01:12:03PM +1100, Andreas Baitis wrote:
>> Hi
>> I'm having trouble with Samba, when I copy large complex directories to my 
>> Samba server, the target doesn't match the source, some files seem to be 
>> missing.
>> *Stats on source(windows client) are:*
>> Size: 4.99 GB (5,367,477,260 bytes)
>> Size on disk: 5.00 GB (5,376,487,424 bytes)
>> Contains: 4,481 files, 281 folders
>> *Stats on target(Samba server) are:*
>> Size: 4.92 GB (5,286,067,654 bytes)
>> Size on disk: 4.92 GB (5,287,628,800 bytes)
>> Contains: 3,733 files, 281 folders
>> I'm thinking it might have something to do with Windows/Linux filename or 
>> path length incompatibility.
>> What Samba settings should I set to ensure this doesn't happen, and are 
>> there any limitations one has to adhere to with regard Windows path length 
>> or filename format in order to ensure directories and files are copied 
>> properly?
>> The problem happens from both XP and Vista clients, the Samba server is 
>> standard Debian etch. Samba 3.0.24
> We'll need much more info than this I'm afraid. What
> directories/files are missing ? Is it repeatable ? Have
> you tried with the latest 3.0.28 release ?
> Pathname limits in Samba 3.0.x are 1024 bytes for the
> full pathname, 256 bytes for each component.
> These limits have been removed for 3.2 and it's down
> to PATH_MAX on the underlying system.
> Jeremy.
Hi Jeremy,

After doing an apt-get update/upgrade samba was updated by apt. The 
version remained the same.

The problem is now fixed.

So I'll explain further as a matter of interest, I'd like to know if it 
was in fact the update that fixed it.

Before the update, I had a look at the files in the command line on the 
server and they were all there, so it was a read/view problem rather 
than a write problem. The files were all in the same directory, and none 
of the paths or file names exceeded the limits you mention. I could not 
see any obvious/consistent differences between the files that were 
visible to the client and the files that were not??

these are some of the files that were visible:

\\server\dean\Quotes\2001 E&S trading 2.doc
\\server\dean\Quotes\2006 DSE Knox.doc

these are some of the files that were not visible:

\\server\dean\Quotes\2001 E&S trading.doc
\\server\dean\Quotes\2001A E&S trading.doc
\\server\dean\Quotes\2003 Hi Fi Supermarket.doc

The problem was repeatable and it was always the same files that were 
invisible to the client (or Samba??).

So the problem seems to be fixed now, but I'm still a little weary, as 
this server is going to be used in a production environment.

I guess I need to find out what updates Debian did to the Etch release 
of Samba recently, see if any of them fit the bill?

Thanks Jeremy

Andreas B.

More information about the samba mailing list