[Samba] Can not add a new NT Workstation to a new (vampired) samba domain

Stephen Vermeulen stephen at vermeulen.ca
Tue Dec 11 04:28:36 GMT 2007

Stephen Vermeulen wrote:
> I am replacing an old NT4.0 Server with a debian 4.0R1 etch Linux 
> server (samba 3.0.24).
> This was with a completely fresh install of debian.
> I first added the samba server (star3) to the old NT4 PDC using the 
> server manager tool
> and then did a:
> net rpc join -S nova -UAdministrator%password
> This worked and I was able to access the machine from the PDC.
> I then did a vampire:
> net rpc vampire -S nova -W BUTLER -UAdministrator%password
> and this worked for most of the user accounts and machine accounts 
> (there were some that
> had errors, but these were mostly for old users or machines that were 
> long since gone), these
> errors look like:
I checked the SIDs of the original NT4 PDC and the samba BDC (after net 
vampire had
run) and they were different.  Could this be causing problems? According 
to this microsoft article:


"... a BDC's relationship to a Domain is identified by it having the 
same computer SID as the other Domain Controllers (DCs)."


More information about the samba mailing list