[Samba] Share does not exist

Sturla Holm Hansen sturla at hitconsult.no
Mon Apr 9 23:33:00 GMT 2007

Hi list, I'm trying to set up a samba server and have run into a problem:
Whenever I try to access a share other than /home/<user> I get a message
saying that this resource is nonexistant on the server...
I have problems getting "net groupmap modify" work, the commands I'm using

net groupmap modify ntgroup="Domain Admins" unixgroup=root
net groupmap modify ntgroup="Domain Users" unixgroup=users
net groupmap modify ntgroup="Domain Guests" unixgroup=nogroup

and the error for all three is:

Can't map to an unknown group type.

I guess this can have something to do with my problems getting shares
other than home to work....

I even tried putting my username in "valid users" for the share "felles"
but still no joy...
The funny part is that I'm using THE EXACT SAME SMB.CONF on another server
that's working fine, I just scp'ed it over, and I'm at a complete loss as
to what I've overlooked.
The directory in qustion has 775/root:users, the user in question is a
member of the users group and I'm sure the smb-password is set correctly
cause I can reach my home folder....

Anyways, here's my smb.conf, if anyone has any good ideas, or can point to
where I'm being stupid I'd really appreciate it :)



   workgroup = HOMENET
   netbios name = sambahome
   server string = %h Homenet (Samba, Debian)
   guest account = nobody

   passdb backend = tdbsam
   security = user
   username map = /etc/samba/smbusers
   name resolve order = wins bcast hosts
   domain logons = yes
   preferred master = yes
   wins support = yes

   # Set CUPS for printing
   printcap name = CUPS
   printing = CUPS

   # Default logon
   logon drive = H:
   logon script = scripts/logon.bat
   logon path = \\server1\profile\%U

   # Useradd scripts
   add user script = /usr/sbin/useradd -m %u
   delete user script = /usr/sbin/userdel -r %u
   add group script = /usr/sbin/groupadd %g
   delete group script = /usr/sbin/groupdel %g
   add user to group script = /usr/sbin/usermod -G %g %u
   add machine script = /usr/sbin/useradd -s /bin/false/ -d
/var/lib/nobody %u
   idmap uid = 15000-20000
   idmap gid = 15000-20000

   # sync smb passwords with linux passwords
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\sUNIX\spassword:* %n\n
*Retype\snew\sUNIX\spassword:* %n\n .
   passwd chat debug = yes
   unix password sync = yes

   # set the loglevel
   log level = 3

   comment = Home
   valid users = %S
   read only = no
   browsable = no
   create mask = 0600
   directory mask = 0700

   comment = All Printers
   path = /var/spool/samba
   printable = yes
   guest ok = yes
   browsable = yes

   comment = Network Logon Service
   path = /home/samba/netlogon
   admin users = Administrator
   valid users = %U
   read only = no

   comment = User profiles
   path = /home/samba/profiles
   valid users = %U
   create mode = 0600
   directory mode = 0700
   writable = yes
   browsable = no

	comment = All Users
	path = /home/samba/felles
	valid users = %U
	force group = users
	create mask = 0660
	directory mask = 0771
	writable = yes

; Set up our PDF-creation print service
	path = /tmp
	printable = yes
	printing = bsd
	guest ok = yes
	print command = /usr/bin/printpdf %s %U
	lpq command =
	lprm command =

More information about the samba mailing list