Brandon Blackmoor bblackmoor at blackgate.net
Fri Apr 6 16:13:42 GMT 2007

Okay, I am starting fresh.

I made a new directory in the root directory, /media, and chmod'ed it 775
recursively. /media and everything in it has rwx for everyone in the "media"

drwxrwxr-x   5 root media  4096 Oct  1  2006 media

"root", "bblackmoor", and "smbguest" are all members of the "media" group.

I deleted the old "media" share and created a new "media" share for the above
directory, set it to guest access, set the guest as smbguest, and set samba to
use SHARE permissions:

        workgroup = MORTSHIRE
        server string = Samba Server
        security = SHARE
        guest account = smbguest
        log level = 3
        log file = /var/log/samba/%m.log
        max log size = 50
        os level = 33
        preferred master = Yes
        local master = No
        domain master = Yes
        dns proxy = No
        wins support = Yes
        guest ok = Yes
        hosts allow = 192.168.1.,
        cups options = raw

        comment = testing media share
        path = /media
        writeable = yes
        browseable = yes
        guest ok = yes

So, according to what I have spent all week reading, I should be able to connect
to this share as a guest and see what's in it.

[root at annwn /]# smbclient //annwn/media2
Domain=[MORTSHIRE] OS=[Unix] Server=[Samba 3.0.23c-2]
Server not using user level security and no password supplied.
smb: \> dir

                57237 blocks of size 4194304. 4170 blocks available

I have tried this with the "smbguest" samba user having no assigned Windows name
or password, and I have tried it with an assigned Windows name and password. The
behavior is exactly the same.

I am open to suggestions. Am I the only person who has ever had this problem?

Brandon Blackmoor
bblackmoor at blackgate.net

More information about the samba mailing list