[Samba] Yet more printing troubles

cmaurand cmaurand at bluetarp.com
Thu Sep 28 22:13:04 GMT 2006

I've gone through the docs and the how to's.  I've installed a printer
under cups, in fact under cups it was a breeze.  Its a Sharp MX4501.  I
have a ppd file for it, it works great from my linux workstation.

I've set up a printer share under samba on my domain controller.  The
windows machines find it, download the driver and then give the error:

"The 'Sharp-4501' printer driver is not installed on this computer.
Some printer properties will not be accessible unless you install the
printer driver.  Do you want to install the printer driver now?"

When I check the \windows\system32\spool\drivers\w32x86\ folder, I find
the drivers there.

When i run rpcclient -Uroot%<password> -c 'getdriver Sharp-4501' <DOMAIN
CONTOLLER> I get the list of files that I should get.  When I run the
same command against a windows XP box, i get the same list of drivers,
but the dependancy drivers (the long list) is in reverse order from the
one I get from the linux machine.  does this make a difference?  If so,
then I would need to re-install the driver again from the rpcclient -c
'adddriver' command, but with the files in the opposite order.

I'm happy to supply any information that I might need to.  However, its
6:00 pm and i have appointments tonight and probably won't be able to
give you any more information before tomorrow.  This problem has been
driving me crazy for a week.

Fedora Core 4, Cups 1.2.1 Samba 3.0.23a

Thanks in advance.

Curtis Maurand
Senior Network & Systems Engineer
BlueTarp Financial, Inc.
443 Congress St.
6th Floor
Portland, ME 04101
207.797.5900 x233 (office)
207.797.3833	  (fax)
mailto:cmaurand at bluetarp.com

More information about the samba mailing list