[Samba] Bad magic on Winbind authentication

sonjag at comcast.net sonjag at comcast.net
Tue Sep 26 12:56:34 GMT 2006

I am running Ubuntu with LTSP authenticating to ADS on a Windows 2003 server 
SP1. My windows side of the network is running fine. The Linux terminals are not 
able to login all users... weirdly, some can, some can't. In my 
log.winbindd-idmap file, I get a slew of entries similar to this:

[2006/09/25 22:54:21, 0] tdb/tdbutil.c:tdb_log(772)
  tdb(/var/lib/samba/winbindd_idmap.tdb): rec_free_read bad magic 0x42424242 at 

I have tried to add a user to the Linux machine and the new Linux users can't 
login either. I'm not sure if they should-- maybe Linux can only see its admin 
and ADS users. 

wbinfo -u gives me a list of all of my users, including those who can and can't 

Solutions I've seen around are deleting files in /var/lib/samba and restarting 
Winbind. Tried that, still not working. Any suggestions?


Sonja Gonzalez
Tech Coord
Ellis School
Fremont, NH

More information about the samba mailing list