[Samba] Setting Windows drivers gives access denied error

Felipe Augusto van de Wiel felipe at paranacidade.org.br
Mon Sep 25 17:31:40 GMT 2006

Hash: SHA1

On 09/19/2006 07:50 AM, Gundemarie Scholz escreveu:
> Good morning!
> For some time I have been experiencing a problem with adding Windows
> drivers for printers available and configured in CUPS already. Not being
> utterly familiar with how the process works I first tried it as root
> from different Windows machines, both W2K and XP Pro. I saw the driver
> files being uploaded, but then got an error message 'Printer settings
> could not be saved. Access is denied.'.
> So I decided to do it 'on foot' like the official Samba-3 book
> describes. Adding the drivers again was not a problem, but setting them
> gave a 'SetPrinter call failed! result was WERR_ACCESS_DENIED'.
> Version of Samba is 3.0.7 on Solaris 5.9, so not the latest one, but it
> used to work, and now it doesn't, without any of my colleagues or me
> having changed a setting (at least not consciously).

	That's *very* strange. Are you sure that nothing changed
in the Samba, CUPS and the OS itself? Did you tried with an early
version of Samba3? (3.0.14a and later).

	Did you check the procedures on the Chapter 22 of the
Official Samba HOWTO? Did you tried the cupsaddsmb?

> testparm smb.conf showed no errors. The relevant bits in smb.conf
> looks like this:
> [print$]
>         path = /usr/local/samba/printers
>         browseable = yes
>         read only = yes
>         write list = root, pcadmin
>         guest ok = Yes

	"guest ok" looks wrong here.

> [printers]
>         comment = Test all printers
>         path = /tmp
>         browseable = no
>         writeable = no
>         printable = yes
>         printer admin = root, pcadmin
>         create mask = 0600
>         guest ok = Yes
>         use client driver =yes


> First I tried setting 'use client driver =no' in the printers section,
> but that didn't make any difference.

	The default is "use client driver = no". Check the manpage
of smb.conf about this paramenter and "disable spoolss", there are
some important points to be considered.

> Then I got advised by a friend to change the following settings:
> [global]
>         log level = 7
>         debug uid = yes
> [print$]
>         printer admin = root, pcadmin
>         #write list = root, pcadmin
> Having done that even copying the drivers failed, so I uncommented the
> write list entry again. Now I have some 1300 lines of output due to the
> high log level, but what should I actually be looking for?

	You should be looking for permission problems to write in
the directory and permission problems to talk with CUPS to
register information, both are possible, depending on your setup.

> Regards,
> Gunde

	Kind regards,

- --
Felipe Augusto van de Wiel <felipe at paranacidade.org.br>
Coordenadoria de Tecnologia da Informação (CTI) - SEDU/PARANACIDADE
http://www.paranacidade.org.br/           Phone: (+55 41 3350 3300)
Version: GnuPG v1.4.5 (GNU/Linux)
Comment: Using GnuPG with Debian - http://enigmail.mozdev.org


More information about the samba mailing list