[Samba] Shares Work, Browsing Doesn't

Hal Vaughan hal at thresholddigital.com
Mon Oct 23 08:11:54 GMT 2006

On Monday 23 October 2006 03:20, you wrote:
> > I just want Windows users to see each Samba server and be able to
> > click through to find the shares and click on the shares to open
> > them.
> Having servers disappear from the browse list is normally related to
> the nameserver daemon.  Are you running nmbd as well as smbd?  smbd
> provides the files, nmbd provides the list of computers.

It's running.  I forgot to give full info, but this is on Debian Sarge 
and installed with aptitude, so it automatically set it up to use smbd 
and nmbd.

> Given that nmbd also uses broadcasts, you might want to make sure
> that broadcasts are definitely reaching all the PCs.
> >         browseable = yes
> >         guest ok = true

Okay, they're gone.

> These two are only supposed to go into a share definition, I'd remove
> them from the main config file just in case.
> >         domain master = Yes

Removed as well, still left in 

	local master = yes
	preferred master = yes

> I'd also disable this if you don't want domain logons - I wouldn't be
> surprised if this does funny things with WINS and affects browsing on
> client PCs.
> The rest of your config looks fine.  I'd make sure nmbd is running,
> and then look at network issues to make sure broadcasts are reaching
> the clients.

Double checked with ps -ax.  It's running/

> If your network is at you can "ping" to
> send a broadcast packet.  In theory you should get replies from many
> PCs, but you may only get responses from Linux PCs, I don't think
> Windows replies to a broadcast ping.  Either way at least one
> response from a different PC should indicate broadcasts are working.

I got responses on a broadcast ping from several computers.

> If you have another Linux PC you can also try using "nmblookup" to
> see if Linux can get a list of names too.

Tried that. Tried:

nmblookup -M server

and I got:

querying server on
name_query failed to find name server#1d

(That's a 1d, as in ONE-d, not an "ell".)

I also restarted after the config changes, with no effect.

Thanks for the suggestions!


More information about the samba mailing list