[Samba] smbd hanging on OS X 10.4.8

nicerobot org.samba at nicerobot.org
Fri Oct 6 18:54:59 GMT 2006

Right, -i was intentional so that I can watch what it's doing from the
command-line, so that I can see the messages as a smbclient attempts to
connect. But it is actually hanging before it ever gets to a point in
the initialization that it will be capable of responding to connection
requests so I'll never see any debugging messages beyond the point where
it hangs.

Jeremy Allison wrote:
> On Fri, Oct 06, 2006 at 02:17:09PM -0400, nicerobot wrote:
>> Sure, I run smbd like this, "smbd -i -d 100 -s /etc/smb.conf", yet
>> startup never completes. It hangs at the point shown below, last line
>> output is "ROOT/HKLM/SYSTEM/CurrentControlSet/Control/: [Print] (data)".
>> It happens regardless of how minimal or extravagant my smb.conf is. I've
>> compared my debugging to the output from Apple's support debugging
>> output and it definitely appears to be something with printer
>> configuration yet I've tried every setting I've found that could affect
>> printer conf and no change.
>> Thanks
> smbd -i means "run interactive", ie. don't become a daemon.
> Of course startup never completes.....
> Try without the -i.
> Jeremy.

More information about the samba mailing list