[Samba] Error: Failed to open /etc/samba/secrets.tbd

Giuoco, Aaron AGiuoco at atlantia.com
Thu Nov 30 17:34:48 GMT 2006

I am trying to integrate a Red Hat Enterprise Linux 4 server into our
Windows 2003 domain.  I was able to successfully join it to our domain,
but the WBINFO commands keep failing when I start SMB and WINBIND.  I
looked at the log files and found this interesting entry in the
/var/log/samba/winbindd.log file:

[2006/11/29 21:49:11, 1] nsswitch/winbindd.c:main(864)
  winbindd version 3.0.10-1.4E.9 started.
  Copyright The Samba Team 2000-2004
[2006/11/29 21:49:11, 0] passdb/secrets.c:secrets_init(64)
  Failed to open /etc/samba/secrets.tdb
[2006/11/29 21:49:11, 0] nsswitch/winbindd.c:main(881)
  Could not initialize domain trust account secrets. Giving up

I read in another posting that you could just delete/rename the
secrets.tdb file and it would get recreated when the services were
restarted.  I tried that and still get the same error.  The WINBIND
service can't seem to read that file.  Anyone know what the problem
could be or how I could troubleshoot it further?

Aaron Giuoco
Systems Admin
Atlantia Offshore Limited
e: agiuoco at atlantia.com
ph: 281-899-4385

More information about the samba mailing list