[Samba] Problem with Samba 3.0.23c-d

daniel at xma.ro daniel at xma.ro
Mon Nov 27 15:13:29 GMT 2006

Hello list !

Today i ran yum update on my corporate server thta runs fedoara core 5.
All went well but i stumbled on the samba update...

My network setup is as follows..

I have a small office network, no domain controller and such.

The setup uses user authentication, and all shares are devided into
departments, each defined group is a department, the groups cannot
access/browse eachothers shares and i map all shares to the root account
so i don't have to mess with permissions relying all authentication to
samba (i know it's not wise).

I used smbpasswd authentication and the samba version was the default
version of fedora core 5 (3.0.21b-2). After the upgrade i couldn't login

The guest account worked like normal after the upgrade but all the other
accounts which required authentication didn't.

After some log digging i discovered that the current version of samba uses
an updated authentication mechanism something about SID's and RID's.

I poke around a little (deleting all the users and starting from scratch
with pdbedit but to no avail). The logs echo an internal error and then it
core dumpes. I searched a local mirror and downloaded the original fc5
samba packages which, for the moment, work like before the update.

If this of some help here's a part of the log file.

[2006/11/27 15:52:30, 0] lib/fault.c:fault_report(41)
[2006/11/27 15:52:30, 0] lib/fault.c:fault_report(42)
  INTERNAL ERROR: Signal 11 in pid 18492 (3.0.23d)
  Please read the Trouble-Shooting section of the Samba3-HOWTO
[2006/11/27 15:52:30, 0] lib/fault.c:fault_report(44)

  From: http://www.samba.org/samba/docs/Samba3-HOWTO.pdf
[2006/11/27 15:52:30, 0] lib/fault.c:fault_report(45)
[2006/11/27 15:52:30, 0] lib/util.c:smb_panic(1599)
  PANIC (pid 18492): internal error
[2006/11/27 15:52:30, 0] lib/util.c:log_stack_trace(1706)
  BACKTRACE: 19 stack frames:
   #0 smbd(log_stack_trace+0x2d) [0xe0d09d]
   #1 smbd(smb_panic+0x5d) [0xe0d1cd]
   #2 smbd [0xdf890a]
   #3 [0xb21420]
   #4 /lib/libc.so.6(__strdup+0x1f) [0x882893]
   #5 /lib/libnsl.so.1(nis_list+0x5d2) [0x611b5f]
   #6 /lib/libnss_nisplus.so.2(_nss_nisplus_setnetgrent+0x8f) [0x31b62e]
   #7 /lib/libc.so.6(innetgr+0xb2) [0x8fdd05]
   #8 smbd(user_in_netgroup+0x65) [0xc43315]
   #9 smbd(token_contains_name_in_list+0x23d) [0xc45d1d]
   #10 smbd(user_ok_token+0x4f) [0xc4610f]
   #11 smbd [0xca3a7f]
   #12 smbd(make_connection+0x194) [0xca51f4]
   #13 smbd(reply_tcon_and_X+0x21d) [0xc68abd]
   #14 smbd [0xca02d0]
   #15 smbd(smbd_process+0x7ab) [0xca140b]
   #16 smbd(main+0xbd0) [0xebbb80]
   #17 /lib/libc.so.6(__libc_start_main+0xdc) [0x82e4e4]
   #18 smbd [0xc2b8a1]
[2006/11/27 15:52:30, 0] lib/fault.c:dump_core(173)
  dumping core in /var/log/samba/cores/smbd

More information about the samba mailing list