[Samba] Strange behavior when join a domain

Rashid N. Achilov achilov-rn at askd.ru
Wed Nov 22 11:21:25 GMT 2006

Samba 3.0.23c, FreeBSD 6.1-RELEASE, Windows domain on W2K Advanced Server. 
When I have tried to join a domain I had have cought with a very strange 

# net ads join -U adminuser -w ASKD
Failed to set servicePrincipalNames. Please ensure that
the DNS domain of this server matches the AD domain,
Or rejoin with using Domain Admin credentials.
Using short domain name -- ASKD
Disabled account for 'SENTRY' in realm 'ASKD.GMBH'

User adminuser is a Domain Admin member, I had have use this login to do a 
kinit, and was succesfull. Computer object created in AD, but stayed 

Samba box have Windows DC as a DNS into a resolv.conf

When I had have tried to join as RPC, that was succesful
# net rpc join -U adminuser -w ASKD
Joined domain 'ASKD'

What can I do here? That's don't annoyed me too much, but I'd like, that's all 
will be "as usual". At home I have W2K3 Enterprise Server with FreeBSD 
6.1-RELEASE into a VMWare box, and I have tried much times to join, rejoin 
and so on with different 'mistakes' at settings - anyway join is succesful!
   With Best Regards.
   Rashid N. Achilov (RNA1-RIPE), Web: http://www.askd.ru/~shelton
   OOO "ACK" telecommunications administrator, e-mail: achilov-rn [at] askd.ru
   PGP: 83 CD E2 A7 37 4A D5 81 D6 D6 52 BF C9 2F 85 AF 97 BE CB 0A

More information about the samba mailing list