[Samba] Unable to Save Permission Changes on "share" on "server" Access Denied.

Jeff Hanchey jhanchey at gsopath.com
Fri Nov 17 21:36:31 GMT 2006

I'm running Samba 3.0.23c-3 on Debian Testing (Etch_) with kernel
2.6.17-2-686.  ACL and XATTR support is built into the kernel.  The
samba package installed has support for ACL and XATTR.  I have a
reiserfs filesystem mounted with the acl and user_xattr attributes.  

I have this box connected to a native mode Active Directory Domain with
kerberos and winbind, which are working correctly.  I can modify the
"share" permissions through a Windows XP Computer Management console for
shares that I create, but I CANNOT modify the file system acls on the
security tab.  I can make the changes I want on the security tab but
when I attempt to apply them, I receive this error:

Unable to Save Permission Changes on "share" on "server"  Access Denied.

I have tried adding a number of options, one at a time, to the smb.conf,
but nothing has worked.  These are a couple of examples:

acl compatibility = win2k
nt acl support = yes
acl map full control = False
admin users = Domain\user (also tried and would rather use: admin users
= Domain\User Group ie...Domain Admins)

Can anyone shed any light on this or where I might have missed
something?  Any help would be greatly appreciated.



More information about the samba mailing list