[Samba] Netbios Problem

Jeff Herbeck jeffherbeck at gmail.com
Sun Nov 12 13:10:30 GMT 2006

Hello Everyone,

I have recently built a new CentOS 4 server and I am having trouble with
Samba and specifically Netbios names.   The server also acts as a router,
firewall, dhcp, and so on.

I have a very simple setup and no matter what I try, I can't get to my samba
server by name.

The servers IP is:

The server name is:


I can not ping www (my XP workstation says "could not find host www")
I can not access my samba shares with \\www

If I type in \\ everything works fine

I kept thinking it was my firewall (shorewall configured with webmin), but
even when I turn the firewall off, I still have the same problem.

I have tried many combinations of opened ports on my firewall with no
success.  Right now I have:

loc to firewall open on UDP 137
loc to firewall open on TCP 137, 138, 139
loc to firewall open on TCP 445

I had a fedora server in the past and samba worked like a dream.

I'm down to a really simple smb.conf.  Here that is:

    workgroup = workgroup
#     netbios name = WWW            (I have tried it with and without this
    security = user
    encrypt passwords = yes


    browseable = yes
    writeable = yes

Here is my hosts file               www.mydomain.com www localhost.localdomain localhost             www

Does anyone have any ideas?

Thanks in advance,


More information about the samba mailing list