[Samba] Cupsaddsmb fails

jpb at bordengrammar.kent.sch.uk jpb at bordengrammar.kent.sch.uk
Fri Nov 3 16:00:45 GMT 2006

Hi All,

I have Samba 3.0.22-1ubuntu4 running on Ubuntu 6.01 (eft) and am trying to
add printers using cupsaddsmb. On running it I get the following:

root at pykota:/home/printeradmin# cupsaddsmb -U root -a -v
Password for root required to access /var/run/cups/cups.sock via SAMBA: 
Running command: smbclient ///var/run/cups/cups.sock/print$ -N -A
/var/spool/cups/tmp/454b654e20cfa -c 'mkdir W32X86;put
/var/spool/cups/tmp/454b654a99ee9 W32X86/AcuLaser-C2000.ppd;put
/usr/share/cups/drivers/ps5ui.dll W32X86/ps5ui.dll;put
/usr/share/cups/drivers/pscript.hlp W32X86/pscript.hlp;put
/usr/share/cups/drivers/pscript.ntf W32X86/pscript.ntf;put
/usr/share/cups/drivers/pscript5.dll W32X86/pscript5.dll'
Connection to  failed

Unable to copy Windows 2000 printer driver files (1)!
root at pykota:/home/printeradmin# 

I know that the right password has been entered and I've tried the name
prefixed with the domain name as well. I've also tried wbinfo -g and -u
which both work and -t works fine. The machine has also been successfully
been attached to the domain and net rpc getsid BGS returns the correct sid.

If anyone can shine some light on this I'd be grateful :)



smb.conf is as below:

        workgroup = BGS
        server string = PYKOTA
        security = domain  
        encrypt passwords = true
        admin users = @admins ew bm jpb
        password server =
        log file = /var/log/samba/log.%m
        log level = 3
        max log size = 50
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        unix charset = ISO8859-15
        os level = 18
        local master = No
        dns proxy = No
        idmap uid = 15000-20000
        idmap gid = 15000-20000
        winbind use default domain = yes
        winbind enum users = yes
        winbind enum groups = yes

########## Printing ##########

# CUPS printing.  See also the cupsaddsmb(8) manpage in the
# cupsys-client package.
 printing = cups
 printcap name = cups

   comment = All Printers
   browseable = no
   path = /tmp
   printable = yes
   public = no
   writable = no
   create mode = 0700

# Windows clients look for this share name as a source of downloadable
# printer drivers
   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes # Have also tried no
   guest ok = no
# Uncomment to allow remote administration of Windows print drivers.
# Replace 'ntadmin' with the name of the group your admin users are
# members of.
 write list = root, @"Domain Admins"

More information about the samba mailing list