[Samba] Re: Unable to open most files within Linux from a windows share

Craig White craigwhite at azapple.com
Thu Nov 2 14:45:07 GMT 2006

On Thu, 2006-11-02 at 14:12 +0000, Crystle Numan wrote:
> Craig White <craigwhite <at> azapple.com> writes:
> > 
> > On Wed, 2006-11-01 at 14:03 -0500, Immanuel CRC Office wrote:
> > > I am trying to open files on my Linux box from a windows share. I can 
> > > browse to the directory, see the files, copy them to my computer, edit 
> > > them, save them and copy the files back (using Nautilus).
> > > 
> > > I can open a text file from the windows share with Gedit.
> > > 
> > > I can not open a text file with Kate: error: The file or folder 
> > > smb://pastor/SHARED FILES/text.txt does not exist.
> > > 
> > > I can not open an .xls file with OOo nor CXoffice Excel. They both open 
> > > a blank sheet - not the file. No error message.
> > > 
> > > System: Ubuntu AMD64: kernel 2.6.15-27-amd64-generic Default
> > > Samba: 3.0.22
> > > 
> > > I've searched to see what others have said, and some say it is KDE's 
> > > fault. Some say it is a problem with OOo.
> > > 
> > > Does anyone have any other ideas or something to try? Do I have to get 
> > > this fixed by OOo and KDE? Let me know if I need to give more 
> > > information. Thanks for any help!
> > ----
> > Logs are your friend...you might want to find them and see if they have
> > any clues.
> > 
> > Seems as though it's more of a permissions thing than a GNOME/KDE/oO
> > thing.
> > 
> > My guess is that you are mounting this share as 'root' and not as 'user'
> > 
> > Did you want to share the appropriate method of mounting (perhaps it is
> > a line in /etc/fstab)?
> > 
> > Craig
> > 
> I do not have a line in /etc/fstab. I simply browse to it through my Places
> menu. I do not know how Ubuntu sets that up. What file info should I post?
> I tried to find a log file, but am not sure if I was looking in the right place.
> The most recently used log in /var/log/samba was log.nmbd and I watched it as I
> tried to open a file from the Windows share. Nothing was added to it. Is there
> another log file I should be watching?
> Would it be helpful to post my smb.conf? That doesn't quite make sense as it
> shows what I am sharing, and that is not the issue.
I think I get it now...you are browsing the share with nautilus which is
a GNOME program. GEdit works because it too is a GNOME program. Other
programs such as Kate are KDE and don't pick up the permissions from

Perhaps you want to use Konqueror to browse/authenticate if you want to
use KDE programs but the better way is to set up a mount in the 'fstab'
with 'user' authentication which would allow any GNOME, KDE or
OpenOffice.org permissions - alas, I am not familiar with Ubuntu but I
would suspect that there is a 'Disk / Filesystems' tool that allows
'root' to create the mount for users - thus become a universally
available network share.


More information about the samba mailing list