[Samba] [SOLVED] Re: Samba can't spool to CUPS. Data not sent to printer

Peter sw98234 at hotmail.com
Wed Nov 1 15:02:09 GMT 2006

On Wed, 01 Nov 2006 01:38:20 +0000, Peter wrote:

> I waited three days to post this while googling, reading, testing. I can't
> figure this out, so am hoping someone here has had a similar problem and
> can recommend a solution.

I should have waited one more day :) I solved the problem by CORRECTLY
installing the HP printer drivers on the client machines. Apparently, (by
not reading the README and associated web documentation from HP), I did
not install the printer drivers properly, therefore, Windows was spitting
out junk. I verified this by adding an lp command and changing to sysv
printing. I was then able to preserve the samba spool job and examine it.
Once I PROPERLY installed the driver, all was fine under sysv or cups
printing (with the raw setting).

My problem was the downloadable drivers contained software which
automatically assumes that you are installing a local printer. This
program never completed because there _was_ not printer hooked up to
USB. The README directed me to the proper subdirectory so I could install
the driver directly.

Hope this helps someone else.

Do not reply to this email, it is a spam trap and not monitored.
I can be reached via this list, or via 
jabber: pete4abw at jabber.org
ICQ: 73676357

More information about the samba mailing list