[Samba] Character encoding problem in file names

Helmut Zimmer helmut.zimmer at gmail.com
Tue May 30 15:05:51 GMT 2006


I'm having some problems with reading files with special characters from
samba shares. The characters are for example 'ä' and 'ö' (and mainly all
umlaut chracters). Before I have been using Fedora Core with ISO8859-1 as
local character encoding and everything was OK when I mounted the samba
share using options "iocharset=iso8859-1,codepage=850" with smbmount
(without these parameters characters were wrong). Now that I changed to
Debian I changed the locale to UTF-8 and since that none of those special
characters have worked. It doesn't matter if I'm accesing a share of a
Windows machine or a Linux machine: everytime the characters are wrong. I
tried "iocharset=utf8" as option to smbmount but it didn't help (am I
perhaps misspelling something?). It seems that there are quite a few
articles and questions about this in the net but still after browsing those
I haven't figured out how to make this work.
So, any tips?

More information about the samba mailing list