[Samba] New Samba installation

Simon Renshaw simon at castortech.com
Thu May 25 19:22:34 GMT 2006


I'm using Samba 3.0.10-1.4E.6 that came with CentOS 4.3 (fresh install)
and Active Directory is running on windows 2003 SP1.

I've been following instructions of the chapter 6 of the HOWTO and would
like to validate the work I did.

First I modified smb.conf:

# Samba config file created using SWAT
# from (
# Date: 2006/05/24 23:51:58

# Global parameters
        workgroup = MONTREAL
        realm = CASTORTECH.COM
        interfaces = eth0
        security = ADS
        wins server =
        password server = castor-srvr1
        encrypt passwords = yes

        comment = Test
        path = /
        read only = No

I didn't modify the krb5.conf file since what was inside was OK. Then I
ran kinit Administrator at CASTORTECH.COM and entered the password. No
error message, it just returned to the prompt. I assume that it worked.
The first time I did get a clock skew error, but I corrected it.

Then I ran net ads join -U Administrator%password. It told me:

Using short domain name -- MONTREAL
Joined 'VLB2' to realm 'CASTORTECH.COM'

So far so good. I can see it in ADUC\Computers.

I think that I'm pretty close but I'm not sure what to do next. I want
that share to be available to anyone on their Windows machine using
their Windows login.

If I try to access \\vlb2, it asks for a username and then gives me an
access denied message is I use MONTREAL\user.

Thanks for the help,

More information about the samba mailing list