[Samba] Problem with adding printer drivers in Windows XP

Tom savagephp at gmail.com
Fri May 12 09:50:26 GMT 2006

Well, for giggles I put 'use client driver' back to 'No' in the 
smb.conf; still doesn't work. Do I need to change 'security = user' to 
'security = domain'?

I've been through all the troubleshooting steps posted in the archives. 
None have worked. Either I've missed something in those archives or mine 
is a new problem. Either way, the crystal ball doesn't seem to be working.

Thanks for the help,


Martin Zielinski wrote:
> Jerry,
> I'd really need your crystal ball sometimes!
> Yes, Tom isn't part of a domain (security = user as default), so he 
> can't su to a "SAVAGEPHP\administrator" or so -  and there is a "use 
> client driver = yes" in the [printers] section of his smb.conf (which 
> has been attached to the original post).
> If the access rights are ok, this should be the reason and I should have
> known.
> Tom?
> Respect,
> Martin
> Ryan Novosielski wrote:
>> Gerald (Jerry) Carter wrote:
>>> Hash: SHA1
>>> Tom wrote:
>>>> Well, I'm trying to add drivers to the server through the Properties
>>>> dialog box for my printer. Right click on the printer, left click
>>>> Properties, Advanced tab, New Driver button type of thing. Except that
>>>> the New Driver button is greyed out. I've checked and my user has the
>>>> SePrintOperatorPrivilege rights assigned to him but it still does not
>>>> work.
>>> * jerry gazes into his crystal ball and then steps up to the mic....
>>> Do you have 'use client driver = yes' ?  If so, disable it
>>> (the default setting).
>> This is a rhetorical question, because I do not know the answer -- 
>> does this user need to be a member of "Domain Admins"?
>> Tom, try "net groupmap list" and see what group is mapped to "Domain 
>> Admins" -- is the user you're connecting as a member of that group? If 
>> not, does making sure that they are make a difference? I'd also ask 
>> you to check to make sure privileges are turned on, but if they 
>> weren't, attempting to add PrintOperatorPrivilege would have failed 
>> with NT_STATUS_NO_SUCH_PRIVILEGE or equivalent.
>> BTW, do you have a [print$] defined, with the proper tree created 
>> beneath it? The directories all have to be there first. Check your 
>> logs for red flags, if there are any. Generally things break farther 
>> down the line, though, so I'm pretty sure it's Samba permissions.

More information about the samba mailing list