[Samba] Problem with automagic Windows drivers

chris at anders.net.au chris at anders.net.au
Wed May 10 02:32:46 GMT 2006

I have the exact same problem, i run many samba PDC and have posted to 
the list
a full on speil about the problem i have with printing.

I have done all the npc rights, i have made sure print$ is writeable 
but when it
goes to the "copying printer drivers" dialog that appears from the printer
wizard, i get an access denied when it tries to update the samba tdb files.

In my rpc rights i have 'DOMAINNAME\root' for the printeroperator but 
it doesnt
seem to hold, privs enable is set... and i have tried all sorts of
combinations, in the end i have resorted to samba 3.0.10 where you can use the
printer admin definition to specify who can upload the driver..

my previous post is below..

Hi guys,

I am at a loss with this feature of samba in that it is soo hit or  miss if
the client drivers will upload or not depending on samba  version

Can someone confirm that this feature does indeed work in the latest  samba

i have tried many setups be it ldap or tdbsam, made sure all more
groupmappings are correct, folders and permissions are correct,
Yet when i go to upload the printer driver the progress window  appears to be
doing something, the logs show me writing to the print$  share and when it
gets to the end i get a nice message stating access

To confirm that its not a permission on the filesystem it self if i  chmod 000
the path of the print$ when i try and upload the driver it  wont even attempt
to upload, windows will simply state that the  operation is not

I am using the root account to upload the drivers, i make sure that  im in the
domain admins group(pdbedit shows primary group SID-512), i  have tried this
with enable privs on and off with the root account  being a part of the
printer manage privs all of which i have no

What makes this even more concerning is that at some sites with  previous
versions of samba i was able to upload the printer drivers  with no drama what
so ever however after upgrading to the latest  version when i goto upload a
new driver or add a printer to the  existing network to upload a new driver
the same problem occurs

I have tried many distros and followed the examples on samba.org,  read the
instructions, the tips, the trix, everything.... This  feature has worked for
me in the past and funny enough at one stage  the drivers would only upload if
i was using winxp to do the  uploading on win2k networks. Now it would seem
that regardless of  what i am doing this feature is broken, unless someone
else from a  fresh install can shed some light on

Distros used : gentoo, debian, freebsd

Thankyou for time,

Kind Regards,

--Chris Anders

Quoting Ryan Novosielski <novosirj at umdnj.edu>:

> Hash: SHA1
> Make sure you look at granting rights to the user. Check out 'net rpc
> rights'.
> ---- _  _ _  _ ___  _  _  _
> |Y#| |  | |\/| |  \ |\ |  | |Ryan Novosielski - User Support Spec. III
> |$&| |__| |  | |__/ | \| _| |novosirj at umdnj.edu - 973/972.0922 (2-0922)
> \__/ Univ. of Med. and Dent.|IST/AST - NJMS Medical Science Bldg - C630
> John Oliver wrote:
>> According to the Classical Printing document, I should browse to the
>> printer share, right-click, choose "Properties", and say No to the
>> question about adding drivers.  Then, at the properties window, I'll be
>> able to add drivers.  But I can't... drivers are greyed out.
>> The doc suggests that I use smbclient to tell if the connection is "set
>> up as a user with printer admin privileges".  But smbclient tells me
>> nothing...
>> [root at localhost samba]# smbstatus
>> Samba version 3.0.21b-2
>> PID     Username      Group         Machine
>> -------------------------------------------------------------------
>> Service      pid     machine       Connected at
>> -------------------------------------------------------
>> IPC$         3968  Mon May  8 14:28:36 2006
>> No locked files
>> I tried making [print$] read only = no but that doesn't help.
>> I also tried guest ok = no to see if I could force it to request a
>> user/pass, so I could try a Samba user in write list, but that didn't
>> change anything either :-(
> Version: GnuPG v1.4.2.2 (MingW32)
> iD8DBQFEYRdkmb+gadEcsb4RAsa8AJ0bDm2LKvzcAmsHYGMDuKkwSW3PxwCgj+Ja
> BEhT9ypjbb/02Yhe+uL+rAw=
> =0CLx
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/listinfo/samba

This message was sent using Zonemail.

More information about the samba mailing list