[Samba] Problem with automagic Windows drivers

John Oliver joliver at john-oliver.net
Tue May 9 16:41:39 GMT 2006

According to the Classical Printing document, I should browse to the
printer share, right-click, choose "Properties", and say No to the
question about adding drivers.  Then, at the properties window, I'll be
able to add drivers.  But I can't... drivers are greyed out.

The doc suggests that I use smbclient to tell if the connection is "set
up as a user with printer admin privileges".  But smbclient tells me

[root at localhost samba]# smbstatus

Samba version 3.0.21b-2
PID     Username      Group         Machine

Service      pid     machine       Connected at
IPC$         3968  Mon May  8 14:28:36 2006

No locked files

I tried making [print$] read only = no but that doesn't help.

I also tried guest ok = no to see if I could force it to request a
user/pass, so I could try a Samba user in write list, but that didn't
change anything either :-(

* John Oliver                             http://www.john-oliver.net/ *
*                                                                     *

More information about the samba mailing list