[Samba] : Win XP Client does not remove directories

Björn Mayer bjoern.mayer at siempelkamp.com
Fri May 5 07:37:05 GMT 2006

1. here are the ethereal-files.
I think the names are kind of self-explanatory, but anyway i will 
explain it shortly:

The following files were recorded from a Windows-XP-Client, who was not 
able to delete a directory on the Samba-Share on the Server
In the second log i additionaly put a file into the directory, which 
should be removed.

The following file was recorded from a Windows-XP-Client, who was able 
to delete a directory on the Samba-Share on the Server

I additionaly made a new file today, which is recorded from a "not 
working" windows client accessing a Test-"Windows Share", where 
directory removing still worked well.

Jeremy Allison wrote:
 > What does this error mean ? "Datei oder Verzeichnis
 > nicht gefunden". That's the strerror output string when
 > the remove_directory call fails.

In english this means
"File or Directory not found."

Mark Johnson wrote:
 >I had a problem very similiar to this with roaming profiles.  The 
 >cause came down to the client and the servers time was not sync'd up. 
  >I never figured out how far off it needed to be before it broke it, 
but >once I sync'd the time, I've never had a problem with the 
directories >since.

First of all, there are no roaming profiles here, but nevertheless i 
gave it a try, but this didn't help.
Today i have a new client, who behaves like that, but for example my own 
PC never showed this behaviour and believe me in the last days i tried 
very much to delete directories ;).

By the way:
I have found some other users in the net, who seem to have a similar 


I also found some interesting reports, talking about fam:

Maybe the bahaviour of windows is sometimes similar with 
GUI-Finux-Filemanagers using fam (whatever fam exactly does).

Always wondering about the spirit of computers and there operating 
systems ;),
Björn Mayer

Jeremy Allison wrote:
> On Wed, May 03, 2006 at 09:12:54AM +0200, Björn Mayer wrote:
>> Hi,
>> its me again. I have to post an addition to my problem described below.
>> Yesterday my error occured again on the same client, who had this 
>> problem last time. I took the chance to do some network sniffing and 
>> compared the traffic from the sometimes bad working client to a good 
>> working client.
>> The interesting fact about this is now, that windows sends two different 
>> types of delete requests ("Delete Directory Request (0x01)" and 
>> First of all here are the relevant captured packets from a well working 
>> connection:
> Don't send text versions of network traces - they aren't much
> use in debugging. Can you send in the actual ethereal trace files
> please ?
> Jeremy

More information about the samba mailing list