[Samba] Subversion on windows showing makefiles modified.

Bill Williams billwilliams at qcsoftware.com
Thu Mar 30 14:23:09 GMT 2006

We are running samba 3.0.10 at work on our server.  It is serving a 
filesystem which contains all of our subversion workspaces for our 

We are using subversion 1.3.0.

The source code and makefile have the eol-style set to native.

When I first created the individual workspaces, I checked them out under 
linux; therefore, all of the files were in unix format.

We generally do our work on windows computers; therefore, as files have 
been modified and committed, they are put back into the workspaces in 
dos format since the windows computers did the commit.

Now here's the issue.  The "svn status" command on windows will show a 
makefile as having been modified when it has not.  This only occurs if I 
update my workspace because another developer modified and committed the 
makefile from their workspace.

At first I thought the problem was because the normal file was in dos 
format while the file in the text-base directory was in unix format.  I 
tried setting both files to unix format and also dos format and still 
get the same result from "svn status" saying the file has been modified.

If I modify a makefile and commit it, "svn status" does not show the 
makefile as being modified after the commit.  I checked and when I do 
the commit in my workspace, the normal file is in dos format and the 
text-base file is in unix format so I sure can't figure out what's going on.

Normal source code files do not have this behavior even though they also 
end up in dos format while the text-base file is in unix format.

To take this a step further, I copied my entire workspace onto my local 
disk on my windows computer and "svn status" does NOT report the 
makefile as having been modified.

By the way, under linux, it does not report the makefile as modified.

More information about the samba mailing list