[Samba] samba does not lock files

Douglas D. Germann, Sr. 76066.515 at compuserve.com
Sat Mar 25 19:49:29 GMT 2006


The problem: Two users can have the same OOo file open at the same time, and
both edit it. The last one to save the file wins!

The system: 3 Ubuntu 5.10 client boxes and one WinXPPro client box, all running
OOo 2.0; one server with RedHat 9.0 running samba version

Did some further testing and found that I could gedit a file at the same time on
both computers, too. Trying to vi the same file on both produced an error in vi,
either at the opening of the file or at the saving. But KWord could have a file
open and edit it when it was open and being edited in gedit. This suggests to me
that it is not wholly an OOo issue, although OOo might have an internal solution.

I tried this, hoping it would be solved by OOo--
but it made no difference. Even did another one changing STAR for SAL, and no
difference either.

When we had all Win95 boxes as clients, our files did seem to lock properly. (We
used Ami Pro 3.1 for word processing, Lotus 1-2-3 for spreadsheets).

So, got any ideas how to trouble shoot this?


:- Doug. 

More information about the samba mailing list