[Samba] Username could not be found

Hakan BAYINDIR acid-burn at myrealbox.com
Tue Mar 21 17:08:22 GMT 2006

I haven't tried that but, samba is correctly logging into the ldap via
rootdn and executing queries. Also I can use it via phpldap admin. samba
uses ldap to auth share accesses and works flawlessly. Also as a note,
slaptest and paramtest (or parmtest I do not remember) returning success
all the time.

Also in the logs of slapd, I see no errors. All queries and log attempts
are returning with err=0.

Craig White wrote:
> On Mon, 2006-03-20 at 21:40 +0200, Hakan BAYINDIR wrote:
>> Hello,
>>     I've asked this question before, and somebody helped me after
>> sending my logs. I thank them very much. I've solved these problems but
>> I still can't join the domain. I cannot see any major problem in the
>> logs except the logging user cannot be found in the ldap DB but it's there.
>>     To summarize the problem to first tmie readers; We have a windows
>> PDC in our organization. We want to migrate this pdc to linux / samba.
>> I've set up one, on a openSuSE 10.0.
>> Windows machine request a log-in when trying to join domain as expected.
>> after supplying user "root" and it's password, it tries to connect and
>> says "username could not be found" wrong basswords return with "Bad user
>> name or passwrd" error and also the shares are working as expected.
>>     I'm attaching the samba logs (level 10), system messages (the slapd
>> messages), my latest smb conf in a tar.gz to not to bug the reader's
>> eye. Thank you for reading and trying to help.
>> I'm woring on this for a long time and I don't have too much time. Help
>> will be very appreciated.
> ----
> I'm not looking at you enclosure.
> can you access your LDAP via the command line...i.e. ldapsearch?
> ldapsearch -x -h localhost -D 'your_rootbind_dn' -W '(ou=People)'
> ?
> Craig

More information about the samba mailing list