[Samba] winbind and schannel errors

Beau Griggs beau_griggs at dot.state.ak.us
Wed Mar 15 16:56:02 GMT 2006

Hello All,

I am having two problems.  I am running Samba on Solaris 10 as a member 
server to a NT 4.0 domain with a PC NetLink 2.0 PDC.

The first problem:  Running Samba 3.0.10 I am able to get the server to 
join the domain just fine with authentication and acls working correctly 
but if the shares aren't accessed for a little while winbind seems to 
halt and I have to start and stop winbind.  A user will call me saying 
that they can't get into their share so I run # getent passwd | grep 
username and nothing shows up so I restart winbind run the command again 
and it works then the user can get back into their share.  Doing some 
research the only thing I could find was to upgrade to the latest 

Now comes in the second problem:  I download the latest version 3.0.21c, 
build it just as I did the previous but when I go to rejoin the domain I 
get this error;

# /usr/local/samba/bin/net rpc join -UAdministrator%xxxxxxxxx
[2006/03/10 21:15:48, 0] 
  cli_rpc_pipe_open_schannel_with_key: cli_rpc_pipe_bind failed with 
[2006/03/10 21:15:48, 0] utils/net_rpc_join.c:net_rpc_join_newstyle(337)
  Error in domain join verification (schannel setup failed): 

Unable to join domain XXXXX

Doing some research the only thing that I've found so far was to add 
'client schannel = no' to my smb.conf file.  Tried it and I get the same 
error.  I don't care which problem some one has a resolution to as long 
as I can get one of these to work I'll be happy.


More information about the samba mailing list