[Samba] Unable to add computer to domain

Wesley Hobbie whobbie81-linuxgeek at yahoo.com
Sun Mar 12 16:57:54 GMT 2006

Ok, I did not know that.  I modified the two files in the /etc/smbldap-tools
folder, although I am still getting the same error.

I looked at the Samba archive for March and I notice some other people seem
to be having the same issue.
March 2 - Bevan Agard
March 6 - Hakan BAYINDIR

I try to add my Windows 2003 Server to the domain and I get an error that
the user name could not be found.  That is when I tried to manually execute
the command that Samba is instructed to use when adding a machine, which is
when I got the error about it cannot contact the LDAP server.

-----Original Message-----
From: Craig White [mailto:craigwhite at azapple.com] 
Sent: Saturday, March 11, 2006 11:35 AM
To: samba at lists.samba.org
Subject: Re: [Samba] Unable to add computer to domain

On Sat, 2006-03-11 at 11:10 -0600, Wesley Hobbie wrote:
> I have an OpenLDAP backend, Samba knows how to talk to it, my Samba 
> users are stored in LDAP and file shares work fine authenticating to 
> the LDAP server. I tried executing smbldap-useradd -w server02 on the 
> command-line and got the following error:
> failed to perform search; Can't contact LDAP server at
> /usr/lib/perl5/vendor_perl/5.8.7/smbldap_tools.pm line 362, <DATA> line
> Error looking for next uid at
> /usr/lib/perl5/vendor_perl/5.8.7/smbldap_tools.pm line 993, <DATA> line
> Anyone have any ideas?
sounds as though you've been using tools other than smbldap to setup user
accounts, etc.

smbldap has to be configured to talk to your LDAP server if you expect it to

depending upon which version of smbldap you are using, your config files
will be in various places but I think the current place is
/etc/smbldap-tools directory these days.


More information about the samba mailing list