[Samba] Fstab mounting error

Mark R. White whitemr at gmail.com
Fri Mar 3 21:31:28 GMT 2006

Try using mount -t cifs instead of mount -t smbfs.  It will work just fine.
Notice my last two mount entries.


mwhite at mwhitelinux:~$ mount
/dev/sda2 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
usbfs on /proc/bus/usb type usbfs (rw)
tmpfs on /dev/shm type tmpfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/sda6 on /home type ext3 (rw)
/dev/sda3 on /usr type ext3 (rw)
/dev/sda5 on /var type ext3 (rw)
tmpfs on /dev type tmpfs (rw,size=10M,mode=0755)
/dev/sdb1 on /mnt/usbdrive type ext3 (rw)
//CORPFPS02/d$ on /mnt/fps02 type cifs (rw,mand)
//CORPFPS03/c$ on /mnt/fps03 type cifs (rw,mand)
mwhite at mwhitelinux:~$

On 3/3/06, Aaron Hawryluk <webmaster at calgarysun.com> wrote:
> Hi all,
> I've googled on this but no luck so far.
> I'm using FC4.  This works flawlessly:
> Mount -t smbfs //host/share /var/mount/hostname/sharename -o
> username=username,password=password,domain=DOMAIN,fmask=0777,dmask=0777
> However, it fails in fstab when I do:
> //host/share /var/mount/hostname/sharename smbfs
> username=username,password=password,domain=DOMAIN,fmask=0777,dmask=0777 0
> 0
> Any ideas?  Is this because it's not root that runs the fstab mounts?
> Because even if I run mount -a as root, still no love.
> ---
> Aaron Hawryluk
> Webmaster, The Calgary Sun
> webmaster at calgarysun.com
> http://www.calgarysun.com
> Office: (403)250-4371
> Cell: (403)828-8677
> Home email: aaron at silicongraffiti.com
> http://www.silicongraffiti.com
> ---
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/listinfo/samba

"Knowledge is power and I like power." Cobra Bubbles, Lilo & Stitch

More information about the samba mailing list