[Samba] Samba 3 by Example - chapter 5 & 6 ( Manager -> sambaadmin)

adrian sender adrian_au1 at hotmail.com
Wed Mar 1 04:45:27 GMT 2006

Hi Gordon,

This is my admin-accts.ldif;
dn: cn=updateuser,dc=tinistuff,dc=com
objectClass: person
cn: updateuser
sn: updateuser
userPassword: {crypt}ABiELdbxGY2fY

dn: cn=sambaadmin,dc=tinistuff,dc=com
objectClass: person
cn: sambaadmin
sn: sambaadmin
userPassword: {crypt}ABiELdbxGY2fY


So the ldap server is stopped, I add these entries; and restart ldap.

[root at node1 scripts]# slapadd -v -l admin-accts.ldif
added: "cn=updateuser,dc=tinistuff,dc=com" (00000002)
added: "cn=sambaadmin,dc=tinistuff,dc=com" (00000003)
Error, entries missing!
  entry 1: dc=tinistuff,dc=com

[root at node1 programs]# ldapsearch -x -D "cn=sambaadmin,dc=tinistuff,dc=com" 
-W uid=sambaadmin
Enter LDAP Password:
ldap_bind: Invalid credentials (49)

It will not let me populate the database either; however I can populate fine 
when using "Manager" instead of "sambaadmin"

[root at node1 sbin]# ./smbldap-populate -a root -k 0 -m 0
Populating LDAP directory for domain TINISTUFF 
(using builtin directory structure)

adding new entry: dc=tinistuff,dc=com
failed to add entry: modifications require authentication at 
./smbldap-populate line 471, <GEN1> line 2.


Hmmmmm :(


>From: Gordon Messmer <yinyang at eburg.com>
>To: adrian sender <adrian_au1 at hotmail.com>
>CC: samba at lists.samba.org
>Subject: Re: [Samba] Samba 3 by Example - chapter 5 & 6 ( Manager -> 
>Date: Sun, 26 Feb 2006 23:08:29 -0800
>adrian sender wrote:
>>Hey Guys,
>>Gordon, I do not think that is the issue; I have tried what you said but 
>>still get the same error.
>>Remember I have a SDC or BDC that uses updateuser; the ldif I add for that 
>>uses plain text passwords and works perfectly.
>I see... Your original message indicated that you had an "updateuser" in 
>the database, but didn't indicate that you were actually using it for 
>I'm still guessing that this is an LDAP issue, and not a samba one.
>Are you able to perform a search with the sambaadmin user, or the 
>updateuser user, using the ldapsearch command line?  Try both of these, and 
>make sure that sambaadmin is not the rootdn specified in your slapd.conf:
>ldapsearch -x -D "cn=sambaadmin,dc=ddesign,dc=com" -W uid=sambaadmin
>ldapsearch -x -D "cn=updateuser,dc=ddesign,dc=com" -W uid=sambaadmin

More information about the samba mailing list