[Samba] Disk quota not working on SAMBA

Richard Bortolucci richardbortolucci at gmail.com
Wed Jun 28 15:59:59 GMT 2006

I'm trying to use disk quota on samba. Everything work through command line,
but when I tried it on Windows, accessing a share with the same user it
did'nt work. Is it necessary to do something different on smb.conf?

Samba were compiled with quota support:
# smbd -b | grep -i quota

Here is the quota for the group group. The user that I'm using has the group
group as primary group:
# quota -g group
Disk quotas for group group (gid 10000):
Filesystem  blocks       quota     limit        grace   files      quota
 limit   grace
/dev/sda4   25286972* 2000000 2000000              54457*  54453  0

When I tried to create a file with this user, through command line, quota
works normally:
$ touch a
touch: cannot touch `a': Disk quota exceeded

When I'm logged on Windows, using the same user, I can create/copy any file
without any advise/problem.

I'm using Suse Linux Enterprise Server 9, with Samba 3.0.20b-3.4-SUSE.

What I need to do?

Richard Bortolucci

More information about the samba mailing list