[Samba] samba-3.0.22 with Heimdal Kerberos - compilation problem

Doug VanLeuven roamdad at sonic.net
Mon Jun 26 21:04:11 GMT 2006

Logan Shaw wrote:
> On Sat, 24 Jun 2006, Doug VanLeuven wrote:
>> Nir Barkan wrote:
>>> I'm trying to compile samba-3.0.22 with Heimdal Kerberos on Solaris 8
>> When I configure & compile from non -standard libs,
>> I explicitly set the paths required.
>> Some people like to put it on the command line, but
>> I created a shell script to invoke configure with my
>> required options and compiler flags.  These are commented on
>> at the end of output from "./configure --help"
>> #!/bin/sh
>> export LIBS="-L/usr/local/ldap/lib -L/usr/local/lib"
>> export CFLAGS="-O2 -L/usr/local/ldap/include -I/usr/local/include"
>> export CPPFLAGS="-I/usr/local/ldap/include"
>> ./configure \
>>     (flag1=opt) \
>>     (flag2=opt)
> On Solaris, you may want to do a "-R" for every "-L" you do
> (if using shared libraries); this will embed the path into the
> executable so that you don't have to LD_LIBRARY_PATH nonsense.
> To the original person with the problem: if you could post your
> compiler command line (the gcc or cc that actually generates
> that error message), that might help, since it would be nice to
> see what -I arguments and so on that the Makefile is passing it.
> Also, by the way,
>     export FOO="bar"
> isn't legal Bourne shell syntax.  It works in ksh and bash, but
> in sh you need
>     FOO="bar" ; export FOO
> or similar.  Of course, on a Linux system /bin/sh often is
> something other than straight Bourne shell, but if you're
> relying on non-Bourne shell features, you should put #!/bin/bash
> or something.
> Not that it matters a whole heck of a lot in a script that is
> designed to wrap "configure", though...

OK OK, I stand corrected.  It's just that it's been years since
I worked on a system that doesn't link sh to ksh or bash.  I
forgot the original vi would bring one out of insert mode
if one tried to move past the ends of the line too.

Thanks for the tip about the -R (-rpath) in LIBS.  I've just been
plugging away with the LD_LIBRARY_PATH or OS equivalent.  Just
never occurred to me.  I'll try that someday.

If one overrides for configure, in samba compiles, the Makefile
gets setup correctly to just run make later.  So it does matter.

At least I can correct the typo in the CFLAGS.  No matter how many
times I look at cut & paste, I usually miss something before posting.

Regards, Doug

More information about the samba mailing list