[Samba] smbclient times out to 445 after upgrade to XP SP2

David Mathog mathog at caltech.edu
Wed Jun 7 15:08:30 GMT 2006

I think this is probably an XP SP2 issue but perhaps you've seen
it before?

We use smbclient 3.0.13 to download files from a machine
"Testmachine" that used to run Windows 2000 and use the
zonealarm firewall.  A couple of days ago it was upgraded
to XP SP2 (fully patched) using the built in
Microsoft firewall.  One folder "Example" was "shared" and the
firewall was configured to allow a connection
for "file and printer sharing" only for our download machine.
Now when we do:

smbclient '\\Testmachine\Example' -U 'Administrator%xxx' -d 3

it logs

Connecting to 131.215.XXX.YYY at port 445
timeout connecting to 131.215.XXX.YYY:445
Connecting to 131.215.XXX.YYY at port 139
Doing spnego session setup (blob length=16)

There's a longish delay between the first and second lines.
(Of course xxx is a real password and XXX.YYY were real numbers
in the original.)

Now here's where it gets strange, from the download machine (linux)

nmap 131.215.XXX.YYY

shows ports 135 and 139, but not 445.  Seems like a firewall
issue, right?  So on the XP box I tried to add port 445 as a
firewall exception, but it wouldn't let me, saying that port was
already used in the firewall.  Presumably under "file and printer
sharing" with 135 and 139, which has an exception for the machine
running nmap, and does show those two ports.  But 445 was apparently
still being blocked.


Finally, I tried to skip the 445 step by appending

 -p 139

to the smbclient line, but it went to 445 first anyway.

Seen this?  Suggestions?  We can still use smbclient now for
this but these timeouts are needlessly slowing down the transactions.


David Mathog
mathog at caltech.edu
Manager, Sequence Analysis Facility, Biology Division, Caltech

More information about the samba mailing list