[Samba] Unable to use 'valid users' from Active Directory

Reese,Richard Stephen rsreese at ufl.edu
Thu Jun 1 20:35:05 GMT 2006

I tried that but the results are the same, I am still prompted to enter
a username and password, and it doesn't take. IMO it shouldn't even
prompt for a username/password because I am already logged in and
therefore authenticated against the domain.

I am getting a error when trying to access the share:

[2006/06/01 16:13:39, 1] smbd/sesssetup.c:reply_spnego_kerberos(250)
  Username UFAD\IF-FRE-CETUS$ is invalid on this system

The username that it mentions is my computer name... 

I've attached my smb.conf in hopes that I am just missing something in
the configuration.

-----Original Message-----
From: Adam Nielsen [mailto:adam.nielsen at uq.edu.au] 
Sent: Wednesday, May 31, 2006 7:50 PM
To: Reese,Richard Stephen
Cc: samba at lists.samba.org
Subject: Re: [Samba] Unable to use 'valid users' from Active Directory

> I am able to return users and groups using wbinfo -g and -u. Samaba 
> will even allow users to connect that are in our domain. The problem 
> exist while trying to narrow down permissions to a share.
> [public]
>    comment = Public Stuff
>    path = /home/
>    public = yes
>    read only = no
>    valid users = @"UFAD\_IFAS-FRE-USERS_autoGS"

Is this a group?  Have you tried with a specific user?  Did you try
removing the quotes?  This works for me:

  valid users = @DOMAIN\user

But I haven't tried it with an AD group.  If you can't get it to work
with an individual user then it's probably a problem with your


More information about the samba mailing list