[Samba] Samba ads not refreshing domain controller group modifications

fiscutean.b at contorgroup.ro fiscutean.b at contorgroup.ro
Thu Jul 27 05:51:37 GMT 2006

I have a big problem with samba and windows 2003 ads. 
I have a DC in win 2003 and centos4.3 with samba ADS.
Registration of samba in ads has gone well , kinit gives no error and also 
net ads join worked well
I can access shares based on the user in my DC, I am not using ACL, only 
the permission in the system and DC.
My problem can be described in the following way. 
-         getent group and getent passwd work well , when I add or delete 
a user from one group the modification is displayed with getent 
-         I chown user:group over a file in samba the user from that group 
can access it 
-         BUT when I delete the user from the group in my DC ,he/she can 
still acces the share even after 24hours until I restart samba and winbind
-         after restart he/she is denied according to group to access the 
Someone says that it could be from my DC but I installed a new DC and a 
new CentOS 4.3 connected over a crossover cable without any policy and the 
same problem.
Last year I had DC with 2000 server and it worked, any modification in 2-3 
minutes was refreshed in samba.
Can anyone give me a tip ?
Thanks in advance for any answer

More information about the samba mailing list