[Samba] W2K3 Domain - Can't Connect to Share?

Gary Dale garydale at torfree.net
Thu Jul 27 23:53:21 GMT 2006

Nolan Garrett wrote:
>  I have a linux box, Samba 3.0.23a, that is joined to a W2K3 domain.
>  I cannot connect to the "MP3s" share (all legal!) on this system - I
>  can connect to home directories and printers.  When I try to connect
>  to MP3s as any user on the domain, I get an Access is denied message,
>  or it prompts me for the username and password again.  I am using
>  Winbind (if that matters), so none of these accounts exist locally on
>  the system.
>  Here is the applicable part of my smb.conf: [MP3s] path =
>  /home/samba/MP3s ;       writeable = no browseable = yes valid users
>  = @"MASSIVEGEEK+Domain Users" writeable = yes
>  And here is the actual file permissions: drwxrwx--- 93 root domain
>  users 4096 Jul 14 18:54 MP3s
>  Any ideas here?  I've tried connecting from several different systems
>  (XP, 2003, Linux), with no luck.  Here is output from smbclient:
>  [root at mgprisvr ~]# smbclient //mggryphont.massivegeek.local/MP3s -U
>  MASSIVEGEEK\\mgwinxpvm1vpn -d 2 added interface ip=
>  bcast= nmask= added interface ip=
>  bcast= nmask= Password: Domain=[MASSIVEGEEK]
>  OS=[Unix] Server=[Samba 3.0.23a-1.fc5.1] tree connect failed:
>  Thank you!
>  Nolan

Your valid users looks a little funny. Have you tried

        valid users = @"Domain Users"


I'm assuming that your server is a member of the domain.

More information about the samba mailing list