[Samba] Re: samba-3.0.23a, get_dc_list failures

Andrei Nazarenko a.nazarenko at gmail.com
Mon Jul 24 19:51:50 GMT 2006

Rex Dieter wrote:

> $ net ads testjoin -d4
> and found that it returns:
> [2006/07/24 10:12:27, 4] libsmb/namequery.c:get_dc_list(1502)
>  get_dc_list: returning 2 ip addresses in an unordered list
> [2006/07/24 10:12:27, 4] libsmb/namequery.c:get_dc_list(1503)
>  get_dc_list:
> which is *totally* not right for our site (not even close).

> running the aforementioned command using samba-3.0.22 does return the
> correct values for get_dc_list.

I believe may be experiencing the same problem.
Today I upgraded from 3.0.22 to 3.0.23a.
I am using "security = ads" and at first everything worked ok.
However, when I tried to access previously mapped share after some
period of inactivity, I started getting errors like this:

get_dc_list: returning 10 ip addresses in an unordered list
[2006/07/24 21:47:13, 4] libsmb/namequery.c:get_dc_list(1503)
[2006/07/24 21:47:28, 1] libads/cldap.c:recv_cldap_netlogon(213)
  no reply received to cldap netlogon

As Rex Dieter above I can confirm that those IP addresses are coming
totally "out of the blue".

I fixed this issue by setting the parameter "password server = " to
the fixed of our LDAP servers. However, I can also confirm that
version 3.0.22 worked ok and did not need this parameter.


Andrei Nazarenko

More information about the samba mailing list