[Samba] tdb/tdbutil.c:tdb_chainlock_with_timeout_internal

Volker Lendecke Volker.Lendecke at SerNet.DE
Sat Jul 22 06:46:22 GMT 2006

On Fri, Jul 21, 2006 at 04:59:51PM -0500, Pappas, Bill wrote:
> Hello. I run samba 3.0.21c on RHEL AS 4 EMT_64 U3 and I've experienced a
> strange problem where smbd will go (and stay) in the D state.  While
> waiting for IO (possibly), these smbd processes do not respond to client
> requests, thus samba appears to be down.  I could not kill these
> processes via kill -9 , so I rebooted which worked.

You need to find out in which system call the processes are
stuck. If it turns out to be the fcntl call on the
secrets.tdb, then Jeremy is right that it is a Veritas bug.
If they are stuck somewhere else then we need to look

strace -p <pid> 

on such a process might show you the syscall where it hangs.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.samba.org/archive/samba/attachments/20060722/03124b94/attachment.bin

More information about the samba mailing list