[Samba] tdb/tdbutil.c:tdb_chainlock_with_timeout_internal

Pappas, Bill Bill.Pappas at STJUDE.ORG
Fri Jul 21 21:59:51 GMT 2006

Hello. I run samba 3.0.21c on RHEL AS 4 EMT_64 U3 and I've experienced a
strange problem where smbd will go (and stay) in the D state.  While
waiting for IO (possibly), these smbd processes do not respond to client
requests, thus samba appears to be down.  I could not kill these
processes via kill -9 , so I rebooted which worked.


The only error I could see out of the ordinary would be (from a smb
client entry on the server under ./samba/var).




I am not giving much to go on, but I can give more information if you
think this error has some link to my problem.  Should I upgrade to the
latest stable and does it address this error?


I will say that ./samba/private is shared between two identical samba
servers running smbd simultaneously.  By shared, I mean that the
./private directory is on a shared filesystem (via Veritas clustered
filesystem).  Each server is running its own independent binaries and
./var/locks. But only one server is running nmbd at time.  The other one
is always ready to start nmbd upon nmbd failure.


If secrets.tdb is shared, would this really only be involved with
nmbd/smbd during domain membership .  BTW - These samba servers are
domain members only. 




Bill Pappas - System Integration Engineer - SAN 

St. Jude Children's Research Hospital

332 North Lauderdale

Memphis, TN 38105

Danny Thomas Tower - Room D1010

Mail Stop 312


More information about the samba mailing list