[Samba] Fedora packages or Enterprise packages of Samba on RHEL4?

Alex de Vaal a.vaal at nh-hotels.com
Tue Jul 11 09:19:39 GMT 2006


Can somebody of the Samba team explain me the difference of Fedora packages
or Enterprise packages ( <http://enterprisesamba.com/>
http://enterprisesamba.com/) of Samba on Red Hat Enterprise Linux 4?

I tried to find any information about this subject, but googleing doesn't
help me.


The standard Samba package (3.0.10EL) of RHEL4 doesn't communicate with a
W2k3 server SP1, while "security=ads" on Samba. This is solved in Samba
version 3.0.14a, so I want to use this package; I use this version on all my
RHL9 servers and this package is very stable!


First I tried the RHEL4 packages from enterprisesamba.com, but these
packages always ended up with the error message "Segmentation fault" while I
used "net ads join"; I recompiled the source of this package because I have
to use the default Kerberos of RHEL4 (which is MIT instead of Heimdal) .
Version 3.0.22 of enterprisesamba doesn't have this problem, but it has the
problem that "security=ads" can't be used (look at thread
http://lists.samba.org/archive/samba/2006-May/120688.html). I need to use
Kerberos on Samba, so "security=domain" (and use NTLM as authentication
mechanism) is no option for me .


Therefore I compiled the Fedora source package on RHEL4 (Fedora is the
playground of RHEL as we all know ;) and this went well. I installed the
Samba rpm's and configured Samba as I have it on RHL9 and started the Samba
daemons (smbd, nmbd and winbindd). The Fedora Samba package is working well
on RHEl4, my XP clients can connect to the shares and I see no error
messages appearing in my Samba logs.


I'd like to continue with the Fedora Samba package on my RHEL4 server, but
I'd like to know why or why NOT to use it! (and why I have to use the
packages of enterprisesamba.com)


Please advise.


Best regards,


More information about the samba mailing list