[Samba] Suse 10.1 with samba servers 3.0.22 & 3.0.23rc3 only seen by Suse 10.1 samba client as cifs

Thomas Garson tgarson at auraltek.com
Wed Jul 5 05:27:15 GMT 2006

Hash: SHA1

I have a Suse Linux 10.1 X86_64 server that is destined to work with a
mixed bag of OS/2, Windows and Linux clients. For this reason, I have
again chosen to use the SMB protocol, which mandates the use of samba. I
started with samba 3.0.22, but ran into some glitches so migrated to

My Linux client is running Suse 10.1 X86_32 with samba client 3.0.22.

I have an OS/2 test system and a Windows 2000 test system.

The Windows 2000 system, with limited testing, has worked well with the
new samba server.

The OS/2 (Warp 4.52) system also seems to be working well with samba
3.0.23rc3, again with limited testing. (A qualified yippee)

I had one H___ of a time getting the Linux client to recognize the samba
shares. I could mount them, but they were unbrowseable. Attempting to
enter a mounted directory would almost freeze the system. After much
tinkering the samba settings via SWAT I was still nowhere.

Just for a lark, I tried mounting the shares as cifs. BINGO, everything
worked. However, this left me in a total state of confusion.

1) The Linux samba 3.0.22 client can log onto my old server (Linux with
samba 2) just fine, as well as the shared directories from my Win2k box,
so obviously it can recognize SMB shares.

2) The OS/2 system, which as far as I know, hasn't got a clue what cifs
is, can mount, and browse, shares from the new server.

3) The Win2K box can mount, and browse, shares from the new server.

4) The new Linux samba client fails to recognize file system of the
shares as SMB, even though the shares can be mounted. But, if I mount
them as cifs instead of smbfs they are usable.

Has there been some kind of hidden parameter relatively recently added
to samba 3 that identifies shares as cifs or smbfs? Is the Linux client
programmed to react to this? Are these protocols becoming mutually
exclusive? If any of this is true, where is the documentation? Why me?

This has given me a headache!
Tom Garson
Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org


More information about the samba mailing list