[Samba] Failed to set servicePrincipalNames 3.023rc3

Henrik Zagerholm henke at mac.se
Mon Jul 3 13:10:21 GMT 2006

Hi jerry,

You were right. ( as usual.. )
I had the wrong FQDN on the samba server.
After reconfiguring my network and I got the FQDN back from  
'hostname' the join worked as planned.


3 jul 2006 kl. 13:45 skrev Gerald (Jerry) Carter:

> Hash: SHA1
> Henrik Zagerholm wrote:
>> Hi list,
>> I get this error when joining my samba server
>> to the domain.
>> Failed to set servicePrincipalNames. Only NTLM authentication
>> will be possible. Please ensure that the DNS domain of
>> this server matches the AD domain, Or rejoin with
>> using Domain Admin credentials.
>> Joined 'CUBE' to realm 'KIC.SE'
>> I joined the same machine to the domain a couple of days
>> ago using samba 3.0.22 and then everything worked OK.
>> I haven't changed anything on the W2k3 Server. (I only
>> removed the old computer account of-course)
>> I've tried to find some explanation for this
>> problem on the big ole net but I only get one
>> google hit ad that is to the svn repo.
> What is the FQDN of yoru server and what is the name
> of the realm?  Are you joining with using a domain admin
> account?
> cheers, jerry
> =====================================================================
> Samba                                    ------- http://www.samba.org
> Centeris                         -----------  http://www.centeris.com
> "What man is a man who does not make the world better?"      --Balian
> Version: GnuPG v1.4.2 (GNU/Linux)
> Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org
> 6OVIEP1qQif1ocye5wJYt1E=
> =hUxs

More information about the samba mailing list