[Samba] usermap ignored?

Martin Hoffmann mhoffmann at pro-nets.de
Tue Jan 31 20:07:32 GMT 2006

Hi listm

i ran into some difficulties using samba 3.0.21b as an PDC while mapping
e.g. "root" to "administrator"
With samba 3.0.10 it worked - however i cannot find anything thats
Can somebody please point me where to look at? Can i test the usermap
functionality somehow except for logging in on windows machine as the
mapped account?
Should "getent passwd" reflect the mapping in any way?

Important parts of my config:
 security = user
 username map = /etc/samba/smbusers
 and ldap backend!

And in /etc/samba/smbusers:
root = administrator admin
Also tried
root = DOMAIN\administrator
root = DOMAIN/administrator
All without luck!

On my windows clients i can only log on using "root" not "administrator"

With the same config 3.0.10 worked! What am i missing here? Did the
behaviour change from 3.0.10 to 3.0.21?

Thanks in advance for any help!

Kind regards,

Martin Hoffmann

More information about the samba mailing list