[Samba] bug - 3.0.14, 3.0.21 intractable browsing problems - help needed

Stephen Bosch posting at vodacomm.ca
Sat Jan 28 02:04:45 GMT 2006


This browsing problem is not going away. We have followed the how-to,
used someone else's "known good" config, perused packet dumps until we
were blue, and tried replicating the setup in a laboratory environment
to see if it was site-specific.

The problem is still there:

If the Samba server is the domain browser, the Network Neighborhood (or
My Network Places) for the domain is empty. As soon we reset the server
to not be a browser of any sort, another machine on the network takes
over, and we see all the hosts. This is even though we can connect to
the Samba PDC and view shares, and even though the Samba PDC knows it's
the browser.

I am at a loss as to how to troubleshoot this. Samba makes wonderful,
wordy logs, but I don't see anything wrong. I've looked through packet
captures, and I have no idea what a "normal" capture is supposed to look
like. We can see all the broadcasts. As I've said, we've tried this in a
lab, and we get the same result. It also happens with 3.0.21.

I'm prepared to go through a step-by-step process in order to track this
down. I'm on a mission. I want to know what's going here, and I think
finding out would benefit the Samba community. But I need assistance
from people who can interpret the log information and understand
SMB/CIFS better than I do.

Perhaps we've missed something really obvious, but I doubt it. At any
rate, I would be happy to be proved wrong.

Asking most sincerely for help,


More information about the samba mailing list