[Samba] Can't Connect to Shares

Eric Hines eehines at comcast.net
Sun Jan 22 20:02:19 GMT 2006

I'm running SUSE 9.3 with Samba 3.0.21a, but I can't connect to some 
shares, even though I can connect to others just fine. I get into my 
home share, netlogon share, printer shares, etc, but three shares all 
get me the same answer in response to <smbclient -L //server/share>: 
I get back an NT_STATUS_BAD_NETWORK_NAME error.  All users are 
correctly in passdb, passwd, etc.  I have winbind running, WINS 
Support=Yes, Samba is set as a PDC (I think--Preferred Master=Yes).

Googling the error message and searching the HOWTO didn't turn up any 
solutions, only the statement that this error generally meant that 
the share was badly formed.  Following are additional tests I've run 
that have failed, and their results:
         from the server side: smbclient //lserver0/<share> -U 
ehines  ==> the BAD_NETWORK_NAME error message  Note: When I run this 
against the working shares, I get the correct response.
         from the Windows device side: net use \\lserver0\<share> ==> 
"System 67 error...network name cannot be found."  Note: When I run 
this against the working shares, I get the correct response.
         nmblookup -B lserver0 __SAMBA__ ==> "querying SAMBA on failed to find __SAMBA__"  even though SAMBA 
clearly is running, and I can connect to it from the Windows devices.
         nmblookup -d 2 '*' works to the extent that it finds the PC 
on one subnet, but it does not find the laptop on another subnet 
(even though the laptop is identical to the PC in terms of 
successful--and failed--access to the shares, and SWAT's STATUS 
function shows the laptop as well as the PC to be active).
         wbinfo -u ==> error looking up domain users
         wbinfo -g ==> error looking up domain groups
         wbinfo -a ehines%passwd ==> NT_STATUS_CANT_ACCESS_DOMAIN_INFO
         wbinfo --get-auth-user ==> no authorized user configured

However, wbinfo -D <DomainName> returns the SID and the correct 
domain name, and
         net rpc info returns the correct domain name and SID.  It 
also returns "5 users," which is all I've set up for now, but it 
returns "Num domain groups: 5" and "Num local groups: 0."  I only 
have 1 domain, so I guess I'm not understanding these responses completely.

The offending share setup from smb.conf (I've only enclosed one; the 
three are essentially identical) is below, together with an excerpt 
from my [global] stanza.  If I've over-snipped the [global], I'll 
send the whole thing, but it's a bit long.

         comment = Accounting Files
         path = /data/accounts
         read only = No

         workgroup = ASTRA_ENT
         netbios name = LSERVER0
         interfaces =,, lo
         bind interfaces only = Yes
         passdb backend = tdbsam
         pam password change = Yes
         unix password sync = Yes
         smb ports = 139
         name resolve order = wins bcast hosts
         shutdown script = /var/lib/samba/scripts/shutdown.sh
         abort shutdown script = /sbin/shutdown -c
         domain logons = Yes
         preferred master = Yes
         wins support = Yes

Thanks a lot for your help.

Eric Hines

There is no nonsense so errant that it cannot be made the creed of 
the vast majority by adequate governmental action.
         --Bertrand Russell

More information about the samba mailing list