[Samba] Cifs client

Jiri Klouda jk at zg.cz
Wed Jan 18 22:49:30 GMT 2006

Hi Max,
I am testing an opaque VFS module with the mount.cifs and I have run
into a similar problem. Everything seems to work, but when I run into
an issue, the kernel freezes the process and sometimes I can recover
by killing the background process (that the VFS is connecting to) but
often I cannot and the only way out is the Magic Key (SysRq-S,SysRq-U,
SysRq-B). You should really look into enabling this in your kernel.

Anyway, for me it happens usually when I copy a file larger than 8Mb
onto the share. If I stick to smaller files, everything goes smoothly.
Please let me know if you find any resolution for this problem on this
or the linux kernel or linux-cifs mailing lists. 

I have tried both with 2.6.8 and 2.6.15 kernels with same result.


PS: I tried to use smbfs, but it has a bug in chmod and every chmod
call will take 30 seconds to timeout for me, so its not much of use.
I think I have filled a bug (2828) for this one, but didn't follow
through with proper debuging info.

On Fri 30-12-05 11:13:21, Max Kipness wrote:
> I've been using the latest cifs 1.8 client at http://linux-cifs.samba.org/
> with Fedora 3 and RHE 4.
> This client seems to have a lot of issues that I did not notice when using
> smbfs. It seems like when there is an issue with connectivity to a windows
> machine, and you try to access a cifs mount, the entire session locks up.
> I basically have to kill the session, log back on, and then there is no
> way to kill the process as it is showing a 'D' for 'waiting for I/O. There
> have been times on various linux servers where I had so many unkillable
> cifs processes that I then could not even do a reboot or shutdown of the
> system. I have had to physically hold the power down to halt the computer.
> My question is whether this in any way relates to Samba itself on the
> system. I see various revisions of the whole Samba suite, but I believe
> these revisions only handle improvements on the server-end.
> Anybody else using cifs for connectivity that has had these issues? Are
> there any ways around this or it is the product just unstable at this
> point?
> Thanks,
> Max
> -- 
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/listinfo/samba

Jiri Klouda <jk at zg.cz>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : http://lists.samba.org/archive/samba/attachments/20060118/b2c5405f/attachment.bin

More information about the samba mailing list