[Samba] Samba - getting long share names from Netapp

Peter Gordon peter at pg-consultants.com
Tue Jan 17 08:44:57 GMT 2006

Hi Adam,

That works for me as well, usually.

The problem is NetApp specific in that  

  net -S server -U username rpc share

fails against Netapp.


On Tue, 2006-01-17 at 17:24 +1000, Adam Nielsen wrote:
> Hi Peter,
> If you create a share >12 chars long testparm gives you this message:
> WARNING: You have some share names that are longer than 12 characters.
> These may not be accessible to some older clients.
> So I imagine that in the past this hasn't worked at all.  It is strange
> though that smbclient would ignore the name entirely without even
> printing some of it (at least this is what happens in 3.0.21rc2.)
> For me though the 'net' command worked, I ran:
>   $ net -S server -U username rpc share
> And providing 'username' was a member of the domain it gave me a list of
> shares, including those longer than 12 characters (however this may be
> because I was connecting to a Samba machine that had joined the domain.)
> Cheers,
> Adam.

More information about the samba mailing list